Skip to content

Releases: ExpressLRS/ExpressLRS-Configurator

ExpressLRS Configurator 1.7.0

19 Jun 08:08
Compare
Choose a tag to compare

Changelog

  • Implemet expert mode #589
  • Upgrade to Electron 27 #582
  • Fix Ubuntu 24.04 compatibility #606 #596
  • Fix Wi-Fi turning on with AUTO_WIFI_ON_INTERVAL disabled #603
  • Add "Flash again" button for massive flashing #588
  • Update gitignore to include windows release files #593
  • Fix regulatory domain override when using manual user defines #602
  • Fix typo in locales.json #613
  • Add Danish translation #585
  • Sort languages list alphabetically in settings screen #605

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.7.0.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.7.0.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.7.0_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.7.0.pacman (Arch)
    • expresslrs-configurator-1.7.0.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.7.0.zip (others)

ExpressLRS Configurator 1.6.1

02 Nov 10:00
Compare
Choose a tag to compare

Changelog

  • Fix issue with Device Target Form #569
  • Unsupported OS Message #562
  • Moved query of log file content to GraphQL #536
  • Support Separate Targets Repo #566
  • Update translations #567

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.6.1.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.6.1.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.6.1_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.6.1.pacman (Arch)
    • expresslrs-configurator-1.6.1.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.6.1.zip (others)

ExpressLRS Configurator 1.6.0

21 Jul 08:15
Compare
Choose a tag to compare

Changelog

  • Add ExpressLRS Cloudbuilds support
  • Add Backpack Cloudbuilds support
  • Add localization support #523 (Thanks @L1cardo!)
  • Add erase and force flash as flashing options #526
  • Add crowdin.com integration #528
  • Fetch locales through http requests to the backend server #531
  • Fix i18next types default namespace path #534
  • Fix error after flashing #538
  • Check if the read config is valid before setting type and frequency #533
  • Fix issue with Auto Updater and I18n #541
  • When filtering the Wi-Fi device selection list, examine the lua name as well as the prior target name #517
  • Add type checking to husky pre commit #543

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.6.0.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.6.0.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.6.0_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.6.0.pacman (Arch)
    • expresslrs-configurator-1.6.0.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.6.0.zip (others)

ExpressLRS Configurator 1.6.0-RC.2

14 Jul 21:13
Compare
Choose a tag to compare
Pre-release

Changelog

  • Add localization support #523 (Thanks @L1cardo!)
  • Add erase and force flash as flashing options #526
  • Add crowdin.com integration #528
  • Fetch locales through http requests to the backend server #531
  • Fix i18next types default namespace path #534
  • Fix error after flashing #538
  • Check if the read config is valid before setting type and frequency #533
  • Fix issue with Auto Updater and I18n #541
  • When filtering the Wi-Fi device selection list, examine the lua name as well as the prior target name #517
  • Add type checking to husky pre commit #543

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.6.0-rc.2.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.6.0-rc.2.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.6.0-rc.2_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.6.0-rc.2.pacman (Arch)
    • expresslrs-configurator-1.6.0-rc.2.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.6.0-rc.2.zip (others)

ExpressLRS Configurator 1.6.0-RC.1

10 Jun 10:10
Compare
Choose a tag to compare
Pre-release

Changelog

  • Add ExpressLRS Cloudbuilds support
  • Add Backpack Cloudbuilds support

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.6.0-rc.1.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.6.0-rc.1.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.6.0-rc.1_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.6.0-rc.1.pacman (Arch)
    • expresslrs-configurator-1.6.0-rc.1.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.6.0-rc.1.zip (others)

ExpressLRS Configurator 1.5.10

25 May 07:48
Compare
Choose a tag to compare

Changelog

  • Rename HappyModel EP to EP1/2 #496
  • Fix HDZero Standalone VRX Backpack target #502
  • Rename "HappyModel EP82 VRX Backpack" target to "HappyModel EP82 VRX Rapidfre Backpack"

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.5.10.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.5.10.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.5.10_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.5.10.pacman (Arch)
    • expresslrs-configurator-1.5.10.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.5.10.zip (others)

ExpressLRS Configurator 1.5.9

27 Apr 11:28
Compare
Choose a tag to compare

Changelog

  • Bugfix: macOS git integration

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.5.9.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.5.9.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.5.9_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.5.9.pacman (Arch)
    • expresslrs-configurator-1.5.9.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.5.9.zip (others)

ExpressLRS Configurator 1.5.8

27 Apr 07:54
Compare
Choose a tag to compare

Changelog

  • Bugfix: Platform IO installer fails if the path to the installer temporary directory is too long in Windows #492
  • Adding NewBeeDrone Alias/target #490
  • Adds Happymodel EPW5 and EPW6 targets #491

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.5.8.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.5.8.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.5.8_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.5.8.pacman (Arch)
    • expresslrs-configurator-1.5.8.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.5.8.zip (others)

ExpressLRS Configurator 1.5.7

24 Apr 07:40
Compare
Choose a tag to compare

Changelog

  • Use different data storage path so Platformio install works again in Windows environment

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.5.7.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.5.7.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.5.7_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.5.7.pacman (Arch)
    • expresslrs-configurator-1.5.7.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.5.7.zip (others)

ExpressLRS Configurator 1.5.6

08 Apr 16:04
2310b6b
Compare
Choose a tag to compare

Changelog

  • Add HDZero goggle backpack target #481
  • Add Foxeer 900M Target
  • Categorize HDZero Goggle VRX Backpack as "Goggles" #484
  • Copy all elrs and bin files to the tmp output directory #480
  • Update Wiki links to remove the version in the URL #478
  • Fix: Check for non-ASCII before using dirtyPath #474
  • Update PIO udev rules link #475
  • Fix auto updater issue caused by event timing #469
  • Actions: Update to Ubuntu 20.04 #466

Which file do I need?

  • Windows (8, 10, 11): ExpressLRS-Configurator-Setup-1.5.6.exe
  • Mac OS X (please
    read macOS install notes): ExpressLRS-Configurator-1.5.6.dmg
  • Linux (please read linux install notes):
    • expresslrs-configurator_1.5.6_amd64.deb (Ubuntu, debian)
    • expresslrs-configurator-1.5.6.pacman (Arch)
    • expresslrs-configurator-1.5.6.x86_64.rpm (Red Hat, Fedora, CentOS)
    • flatpak install org.expresslrs.ExpressLRSConfigurator (Flatpak distribution format)
    • expresslrs-configurator-1.5.6.zip (others)