Skip to content
/ biyi Public

Biyi (比译) is a convenient translation and dictionary app written in Flutter.

License

Notifications You must be signed in to change notification settings

lijy91/biyi

Repository files navigation

biyi

GitHub (pre-)release GitHub (pre-)release

Biyi is a convenient translation and dictionary app written in Flutter. View document

"Biyi" (比译) is the Chinese word for "Comparison + translation".


English | 简体中文


Platform Support

Linux macOS Windows
✔️ ✔️ ✔️

Installation

Downloads are available on the Releases page. Also check out the website for other installation methods.

To install with Homebrew, run:

brew tap biyidev/biyi
brew install biyi

Development

We welcome you to join the development of Biyi.

Please make sure to read the Contributing Guide before making a pull request.

⚠️ Linux requirements

Run the following command

sudo apt-get install appindicator3-0.1 libappindicator3-dev
sudo apt-get install keybinder-3.0

Before You Start

  1. Create working directory
$ mkdir ~/biyidev
$ cd ~/biyidev
  1. Clone this repo via git:
$ git clone https://github.com/biyidev/biyi.git
  1. Change to biyi directory
$ cd ~/biyidev/biyi
  1. Install dependencies
$ melos bs

Run app

$ cd apps/biyi_app
$ flutter run -d linux / macos / windows

Discussion

Welcome to join the discussion group to share your suggestions and ideas with me.

Related Links

License

AGPL