Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The method to avoid the bug "/proc/self/fd/11: No such file or directory". #290

SerialCore opened this issue Dec 11, 2023 · 1 comment


Copy link

SerialCore commented Dec 11, 2023

Recently, I found a serious bug that the command

bash <(curl -L

refused to work due to the error "/proc/self/fd/11: No such file or directory". This happened even for help, version and check options applied. Thus, I thought it should have nothing to do with the script itself, but something magic. After a few attemptings, this bug has been solved by executing the following command

bash -c "$(curl -L https:/"

with root of course.

Copy link

hankji commented Dec 21, 2023

I got the same error

then, I found that :
1 use wget download the
2 bash

it works for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
None yet
None yet

No branches or pull requests

2 participants